Date

Have you recently upgraded approx (say from Debian Lenny to Squeeze) and had these errors whenever you apt-get update from multiple systems to an approx server?

The problem is a result of approx switching from an independent daemon to using inetd, which does not support many connections out of the box. The fix is this:

Edit /etc/inetd.conf and change: 9999 stream tcp nowait approx /usr/sbin/approx /usr/sbin/approx
to:
9999 stream tcp nowait.9999 approx /usr/sbin/approx /usr/sbin/approx

The nowait.9999 means accept at least 9999 simultaneous (the first 9999 is the port number). The inetd default is to refuse more than 256 simultaneous connections which is easy to overwhelm with several systems simultaneously running apt-get.


Comments

comments powered by Disqus